Screw-Verse

I’ve been a loyal AT&T customer for a very long time. Probably longer than most other people, I would imagine, although I could be wrong.

I was with AT&T when they were Southwestern Bell Wireless, and that was 18 years ago. I saw them through Cingular Wireless and into AT&T, and I was among the first of the customer base in North Texas to sign up for U-Verse when they rolled out fiber optic. While many have experienced poor customer service through AT&T I’ve always said I’ve been lucky and never had those experiences.

All that has changed. Since early March I’ve had so many problems with these people I feel as though I’m now paying for the 18 years of stellar service I’ve received all at once. I’ve finally hit that point of rage with AT&T. I’ve joined the ranks of dissatisfied customers.

UVerseRageGuy

 

Around the beginning of March, we came home from a trip to Dallas only to find that our neighbor’s tree had fallen in his back yard earlier that day, taking down the phone and power lines. Evidently, we missed one heck of a storm. I had to call AT&T to report the issue. Evidently, no one else had made the call. Unfortunately, they sent an “inside” tech out to fix the problem, when it was clear it was an outside issue at the time. I mean, seriously…. the power lines were down in my back yard. I already had to wait for two days for someone to come out on this problem. I was livid he couldn’t do anything now that he was here. I called support again and was in “customer-from-hell” mode. They managed to send the appropriate tech out within an hour and we got service that day (March 10th). However…

It should be noted that the outside tech they sent out routed us to a different node (or did something…) until the damage could be repaired. Prior to the outage, we were getting the download speeds we were paying for (18mbps, or roughly thereabouts). After his visit the speeds varied anywhere between 6mbps to 14mbps, but more often than not, our signal would drop completely. Sometimes we would go 30 minutes without being able to connect, then we’d get a very slow connection. But if we tried again, it would be fine. It had no pattern; no rhyme or reason, no possible way to troubleshoot.

I’ve had inside techs out here trying to fix the problem. I’ve called AT&T support trying to get help over the phone. The people I get on the phone don’t know what they’re doing. They’re following a script and they take me through steps I’ve already done. They don’t listen to me when I tell them this isn’t machine specific, nor is it related to a computer at all (we experience it on the Roku as well). I’ve had one phone tech ignore my request to speak with her manager. I’ve finally just had it. Every time I think about calling them I just want to throw my phone.

I did find out one very important thing: We have U-verse in my neighborhood but they aren’t running it on fiber optic cable. They’re still using the 30+ year old copper wire. I didn’t think they could install U-Verse in an area that wasn’t fiber optic yet. When U-Verse first launched, I remember hearing it was designed for fiber optic. Oh, and they don’t have an ETA on when my neighborhood is getting fiber optic, either, btw…

gtfo-rage

I called Comcast yesterday. We have an installation appointment for this Friday. I’m so looking forward to that next call to AT&T.

Advertisements

~ by Duch on April 15, 2015.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: